Error running more than two Citrix VUsers in load test only: “Error: Got unexpected disconnect event, exiting …”

Error running more than two Citrix VUsers in load test only: "Error: Got unexpected disconnect event, exiting …"

Problem

Environment:

LoadRunner 11 Patch 2

Citrix XenApp Online Plugin 12.1

Citrix XenApp Server 6

When running a loadtest using the Citrix protocol, more than two VUsers fails with the error "Error: Got unexpected disconnect event, exiting …"

The Citrix and Terminal Server settings described in KB KM766573 were checked, and were not found to be the problem.

Cause

Starting with the Citrix XenApp plugin v 11.2 and onward, the LoadRunner Agent must run as a process. By default, it runs as a service.

Fix

Change the LoadRunner Agent on the load generator to run as a process rather than a service. One way this can be done by using the HP LoadRunner Agent Run Time Settings configuration tool (in Start|All Programs folder), and selecting "manually log in to this machine".

NOTE: It is not recommended to run Citrix vuser scripts on the LoadRunner controller, other than for troubleshooting purposes, rather separate load generators should be used.

Advertisements

One thought on “Error running more than two Citrix VUsers in load test only: “Error: Got unexpected disconnect event, exiting …”

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s