Error -26547: Authentication required, please use web_set_user in LoadRunner

Action.c(12): Error -26547: Authentication required, please use web_set_user, e.g. web_set_user("domain\\user", "password", "host:port"); [MsgId: MERR-26547]

After adding the web_set_user() as suggested in the error message a further error is received:

Error -26630: HTTP Status-Code=401 (Access Denied) for "http://<website>" [MsgId: MERR-26630]

LoadRunner does not currently support Microsoft Distributed Password Authentication (DPA)

To determine if DPA is being used in the generation log look at the header in the Server response to the initial GET. The following is an example server response:

HTTP/1.1 401 Access Denied\r\n

Server: Microsoft-IIS/5.0\r\n

Date: Fri, 15 Jan 2010 11:07:04 GMT\r\n

WWW-Authenticate: DPA\r\n

Content-Type: text/html\r\n

Cache-Control: proxy-revalidate\r\n

Content-length: 616\r\n

Proxy-Connection: Keep-Alive\r\n

Connection: Keep-Alive\r\n

Proxy-support: Session-based-authentication\r\n

Note the WWW-Authenticate:DPA

There is currently no workaround available

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s